Selectiva Doble

Fuente: Aprende Fácil.
21 del 1 de 2010

La esctructura selectiva doble permite elegir entre dos opciones o alternativas, en función del complimiento de una determinada condición, de tal forma que, si se cumple, se ejecutan las acciones del primer bloque; sino se cumple, se ejecutan las acciones del segundo bloque.

Sintaxis para la esctructura de Decisión en Pseudocódigo

Si <condición> Entonces
<bloque de instrucciones 1>
Sino
<bloque de instrucciones 2>
Fin Si



Ejecutara el primer bloque de sentancias si la condición resulta verdadera. En caso de que la condición sea falsa ejecutará el segundo bloque de sentencias.



Sintaxis para la esctructura de Decisión en Diagrama de Flujo


Sintaxis para las condiciones en csharp (C#)
A) Para cuando hay una instrucción


if (<condicion>)
<instrucción>;
else
<instruccion>;

B) Para cuando hay más de una instrucción
if (<condicion>)
{
<instrucción1>;
<instrucción2>;
<instrucción3>;
}

else
{
<instrucción1>;
<instrucción2>;
<instrucción3>;
}



Ejemplo:
Algoritmo que determina si una calificación es aprobatoria o no, considerando el 70 como mínimo aprobatorio.

Pseudocódigo
1.- Inicio
2.- Calif 0
3.- Leer "Calificación: ", Calif
4.- Si Calif >= 70 Entonces
----Imprimir "Aprobado"
5.- Sino
----Imprimir "No aprobado"
6.- FinSi
7.- Fin



Diagrama de Flujo




Aplicación en C#


//Codigo del boton "OK" al hacer click
private void button1_Click(object sender, EventArgs e)

{
//Declaracion de variables
int Calif;


//Asignacion de valores a las variables
Calif = System.Int32.Parse(txtCalif.Text);


//Condicion que determina si es aprobatoria o no
if (Calif >= 70)
lblDesp.Text = "Aprobatoria";

else
lblDesp.Text = "No aprobatoria";
}








comments powered by DisqusRecomendar a un amigo